Texte à méditer :  Si tu te lèves avec l'envie de travailler, recouche-toi, ça passera  
Le Blog - Astuce

 

Rubriques

Astuce

Commerce

Coup de gueule

Evolution de 366 Jours par An

Pub - Coup de coeur

Pub stupide

SPAM

Tristesse

Vie moderne


Derniers billets
Derniers commentaires

Astuce

Dédoublonner un fichier Excel  -  par Yves

Dédoublonner un fichier Excel



J'ai un fichier sous Excel d'à peu près 10 000 lignes, dont certaines reviennent en doublon. je veux supprimer les doublons.

Il suffit de :

1) Sélectionner les données à dédoublonner, et les trier. (cela va mettre côte à côte les cellules contenant les mêmes choses)

2) Insérer une colonne juste à côté pour y coller à chaque ligne le test : "est-ce que la cellule du dessous contient la même chose que la cellule de cette ligne ?"

3) Copier toute cette dernière colonne, et la recoller par dessus par valeur en collage spécial (pour que ça ne change plus par la suite)

4) Sélectionner les données à dédoublonner avec la colonne de 0(=unique) et 1(=au moins en double), et les trier selon la 2ème colonne (toutes les données qui sont déjà présentent vont se retrouver en bas de liste, il ne suffira plus qu'à les supprimer).

5) Supprimer la colonne qui a servi aux tests.

Concrètement :
Si les données vont de A1 à A10
Par exemple, utilisons la colonne B pour les petites formules
B1 contiendra =SI(A1=A2;1;0)
Copier coller B1 jusqu'à B10
etc.
Remarque : Si on ne veut pas perdre l'ordre original des données, il suffit d'insérer une colonne, avant le tout premier tri, pour y mettre un compteur de lignes (1, 2, 3, 4 etc.) en face de chaque donnée (à copier coller par valeur si c'est fait avec une formule). Après le point 5) il suffira de retrier selon cette colonne pour retrouver l'ordre d'origine.

Autre remarque : la comparaison est insensible à la casse donc BONJour et bonjOuR vont être identique par contre évidemment ce n'est pas insensible aux accents (Michael vs Michaël seront différents).

Dernier point, la cerise sur le gâteau : si ce sont des lignes de textes que vous avez en doublons (citations, adresses mail, ...) il existe un petit outil de dédoublonnage de listes en ligne : http://www.outils.manit4c.com/dedoublonnage.php#result
Publié le 27/09/2010 @ 22:16  
Tous les billets  Prévisualiser  Imprimer l'article 


Commentaires


Personne n'a encore laissé de commentaire.
Soyez donc le premier !

Archives
04-2019 Mai 2019 06-2019
L M M J V S D
    01 02 03 04 05
06 07 08 09 10 11 12
13 14 15 16 17 18 19
20 21 22 23 24 25 26
27 28 29 30 31    
Billets des amis
Design : Astrographisme © 2007 - Image : aimable courtoisie de © Christophe Vacher - Licence Creative Commons
^ Haut ^